Vulnerabilities / Link Library / WPSEC-2026-2352

Link Library <= 7.10.0 - Unauthenticated Sensitive Information Exposure via RSS Preview

Medium 5.3 CWE-200Fixed in 7.10.1
ID
WPSEC-2026-2352
Plugin
Link Library (link-library)
Affected
all versions before 7.10.1
Remediation
Update to 7.10.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
Link Library on WPSec AttackSurface
Fix released
Published

Description

The Link Library plugin for WordPress is vulnerable to Sensitive Information Exposure via the RSS preview feature in all versions up to, and including, 7.10.0 due to the preview handler accepting any supplied post ID without checking that it is a published link library entry. This makes it possible for unauthenticated attackers to view the title, RSS feed URL and site URL of unpublished links that have an RSS feed set, such as pending or draft submissions.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0