Vulnerabilities / Link Library / WPSEC-2026-2353

Link Library <= 7.10.0 - Unauthenticated Stored Cross-Site Scripting via Link Description and Notes

Medium 5.4 CWE-79Fixed in 7.10.1
ID
WPSEC-2026-2353
Plugin
Link Library (link-library)
Affected
all versions before 7.10.1
Remediation
Update to 7.10.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
Link Library on WPSec AttackSurface
Fix released
Published

Description

The Link Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via link descriptions, notes and text fields in all versions up to, and including, 7.10.0 due to the 'use HTML tags' option converting square brackets into angle brackets without any escaping when rendering links. Because link descriptions and notes can be supplied through the front-end user link submission form, this makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute whenever a user views the link list. Exploitation requires the HTML tags option to be enabled and the submitted link to be displayed.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0