Vulnerabilities / WP Datepicker / WPSEC-2026-2358

WP Datepicker <= 2.1.6 - Authenticated (Administrator+) Stored Cross-Site Scripting via Date Format and Date Range Settings

Medium 4.4 CWE-79Fixed in 2.1.7
ID
WPSEC-2026-2358
Plugin
WP Datepicker (wp-datepicker)
Affected
all versions before 2.1.7
Remediation
Update to 2.1.7 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
WP Datepicker on WPSec AttackSurface
Fix released
Published

Description

The WP Datepicker plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the datepicker date format, default date and date range settings in all versions up to, and including, 2.1.6 due to insufficient output escaping when the values are printed into generated JavaScript. This makes it possible for authenticated attackers, with administrator-level access and above, to inject arbitrary web scripts that execute in pages loading the generated script. This only affects multi-site installations and installations where unfiltered_html has been disabled.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0