Vulnerabilities / Motors / WPSEC-2026-2360

Motors <= 1.4.128 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Listing Term Names

Medium 6.4 CWE-79Fixed in 1.4.129
ID
WPSEC-2026-2360
Plugin
Motors – Car Dealership & Classified Listings Plugin (motors-car-dealership-classified-listings)
Affected
all versions before 1.4.129
Remediation
Update to 1.4.129 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
Motors on WPSec AttackSurface
Fix released
Published

Description

The Motors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via user-submitted listing term names in all versions up to, and including, 1.4.128. This is due to insufficient input sanitization of term names used to generate listing titles and insufficient output escaping, as the generated titles were output in HTML attributes using wp_kses_post() and in the similar listings template without any escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an affected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0