Vulnerabilities / Style Kits for Elementor / WPSEC-2026-2362
Style Kits for Elementor <= 2.6.6 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
Medium 6.4
CWE-79Fixed in 2.7.0
- ID
- WPSEC-2026-2362
- Plugin
- Style Kits for Elementor (analogwp-templates)
- Affected
- from 1.9.5 before 2.7.0
- Remediation
- Update to 2.7.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Style Kits for Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The Style Kits for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG file uploads in versions 1.9.5 up to, and including, 2.6.6. This is due to the plugin adding the SVG MIME type to the allowed upload types for every user who can upload files while sanitizing SVG files on only one of WordPress's two upload paths. This makes it possible for authenticated attackers, with Author-level access and above, to upload SVG files containing arbitrary web scripts that execute whenever a user accesses the uploaded file.
References
- https://wpsec.com/vuln/WPSEC-2026-2362/
- https://plugins.svn.wordpress.org/analogwp-templates/tags/2.7.0/
- https://wordpress.org/plugins/analogwp-templates/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS