Vulnerabilities / WCFM Marketplace / WPSEC-2026-2372

WCFM Marketplace <= 3.8.3 - Unauthenticated Missing Authorization to Setup Wizard Access and Plugin Installation

Medium 5.3 CWE-862Fixed in 3.8.4
ID
WPSEC-2026-2372
Plugin
WCFM Marketplace – Multivendor Marketplace for WooCommerce (wc-multivendor-marketplace)
Affected
all versions before 3.8.4
Remediation
Update to 3.8.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
Attack surface
WCFM Marketplace on WPSec AttackSurface
Fix released
Published

Description

The WCFM Marketplace plugin for WordPress is vulnerable to unauthorized access to its setup wizard in all versions up to, and including, 3.8.3, due to a missing capability check. The wizard runs on admin_init whenever the 'page' parameter is 'wcfmmp-setup', and its plugin install handlers are protected only by nonces that the wizard prints to every visitor. This makes it possible for unauthenticated attackers to open the marketplace setup wizard through wp-admin/admin-ajax.php and use its install handlers to download, install and activate the WooCommerce, WCFM (WC Frontend Manager) and WCFM Membership plugins from WordPress.org when they are not already active.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0