Vulnerabilities / WCFM Marketplace / WPSEC-2026-2374

WCFM Marketplace <= 3.8.3 - Authenticated (Store Vendor+) Stored Cross-Site Scripting via Store Video Banner

Medium 6.4 CWE-79Fixed in 3.8.4
ID
WPSEC-2026-2374
Plugin
WCFM Marketplace – Multivendor Marketplace for WooCommerce (wc-multivendor-marketplace)
Affected
all versions before 3.8.4
Remediation
Update to 3.8.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
Attack surface
WCFM Marketplace on WPSec AttackSurface
Fix released
Published

Description

The WCFM Marketplace plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the store video banner in all versions up to, and including, 3.8.3 due to the banner embed replacing only the YouTube URL inside the value and printing the rest of it without escaping. This makes it possible for authenticated attackers with vendor-level access to inject arbitrary web scripts that execute whenever a user visits the store page or the store list.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0