Vulnerabilities / WP Map Block / WPSEC-2026-2383

WP Map Block <= 3.1.0 - Authenticated (Author+) Sensitive Information Exposure via Map Post Type Data Sources

Medium 4.3 CWE-200Fixed in 3.2.0
ID
WPSEC-2026-2383
Plugin
WP Map Block – Google Maps, OpenStreetMap, Mapbox, Store & Shop Locator, Directory, Listings & Filters (wp-map-block)
Affected
from 3.0.0 before 3.2.0
Remediation
Update to 3.2.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
WP Map Block on WPSec AttackSurface
Fix released
Published

Description

The WP Map Block plugin for WordPress is vulnerable to Sensitive Information Exposure via post type and listing data sources in all versions up to, and including, 3.1.0. This is because data sources accepted any registered post type, including non-public ones, and did not exclude password-protected posts. The public map search REST endpoint also resolved these sources without applying the plugin's feature gating. This makes it possible for authenticated attackers, with author-level access and above, to save a map that pulls titles, excerpts or content snippets, and links from non-public post types or password-protected posts, and then read them, or let anyone read them, through the public map search endpoint.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0