Vulnerabilities / WP Map Block / WPSEC-2026-2384

WP Map Block <= 3.1.0 - Authenticated (Contributor+) Missing Authorization to Usage Tracking Opt-In

Medium 4.3 CWE-862Fixed in 3.2.0
ID
WPSEC-2026-2384
Plugin
WP Map Block – Google Maps, OpenStreetMap, Mapbox, Store & Shop Locator, Directory, Listings & Filters (wp-map-block)
Affected
from 3.0.0 before 3.2.0
Remediation
Update to 3.2.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
WP Map Block on WPSec AttackSurface
Fix released
Published

Description

The WP Map Block plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 3.1.0. This is because the /onboarding/subscribe and /gift/optin REST routes only checked for the edit_posts capability. These routes change the site-wide usage-tracking consent of the bundled SDK, which is an administrator's decision. This makes it possible for authenticated attackers, with contributor-level access and above, to opt the site into or out of usage tracking and send consent details to the vendor without administrator approval.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0