Vulnerabilities / WP Map Block / WPSEC-2026-2385

WP Map Block <= 3.1.0 - Authenticated (Author+) Stored Cross-Site Scripting via Map Data Source Marker Popups

Medium 6.4 CWE-79Fixed in 3.2.0
ID
WPSEC-2026-2385
Plugin
WP Map Block – Google Maps, OpenStreetMap, Mapbox, Store & Shop Locator, Directory, Listings & Filters (wp-map-block)
Affected
from 3.0.0 before 3.2.0
Remediation
Update to 3.2.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
WP Map Block on WPSec AttackSurface
Fix released
Published

Description

The WP Map Block plugin for WordPress is vulnerable to Stored Cross-Site Scripting via marker popups built from GeoJSON and REST data sources in all versions up to, and including, 3.1.0. This is due to insufficient output escaping in the popup renderer: marker titles were inserted into the popup HTML unescaped, marker content was inserted as raw HTML, URL attributes only had double quotes escaped, and link and image URLs were not limited to safe schemes. The map builder preview loads these data sources even on sites without the paid add-on. This makes it possible for authenticated attackers, with author-level access and above, to save a map whose data source points to attacker-controlled JSON. The injected scripts then run when a user, such as an administrator, opens the map in the builder (or views it on a site where dynamic data is enabled) and opens a marker popup.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0