Vulnerabilities / WCK / WPSEC-2026-2388

WCK <= 2.3.9 - Reflected Cross-Site Scripting via Upload Field

Medium 6.1 CWE-79Fixed in 2.4.0
ID
WPSEC-2026-2388
Plugin
Custom Post Types and Custom Fields creator – WCK (wck-custom-fields-and-custom-post-types-creator)
Affected
all versions before 2.4.0
Remediation
Update to 2.4.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
WCK on WPSec AttackSurface
Fix released
Published

Description

The WCK plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'postedvalues' parameter rendered in the upload field in all versions up to, and including, 2.3.9. This is due to insufficient input sanitization and output escaping: the value decoded from the parameter is echoed without escaping into the upload field's hidden input value attribute and its data-attachment_id attribute. This makes it possible for unauthenticated attackers to inject arbitrary web scripts into pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0