Vulnerabilities / iChart – Easy Charts and Graphs / WPSEC-2026-2396
iChart – Easy Charts and Graphs <= 2.2.3 - Authenticated (Subscriber+) Insecure Direct Object Reference to Chart Data Overwrite
Medium 4.3
CWE-639Fixed in 2.2.4
- ID
- WPSEC-2026-2396
- Plugin
- iChart – Easy Charts and Graphs (ichart)
- Affected
- all versions before 2.2.4
- Remediation
- Update to 2.2.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-639
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- iChart – Easy Charts and Graphs on WPSec AttackSurface
- Fix released
- Published
Description
The iChart plugin for WordPress is vulnerable to Insecure Direct Object Reference via the qcld_ichart_save_datasets AJAX action in all versions up to, and including, 2.2.3. This is due to missing validation that the current user can edit the post given in the user-controlled 'post_id' parameter. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the chart datasets and colour codes stored in the post meta of arbitrary posts.
References
- https://wpsec.com/vuln/WPSEC-2026-2396/
- https://plugins.svn.wordpress.org/ichart/tags/2.2.4/
- https://wordpress.org/plugins/ichart/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS