Vulnerabilities / Posts Table with Search & Sort / WPSEC-2026-2404
Posts Table with Search & Sort <= 1.4.14 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'date_format' Shortcode Attribute
Medium 6.4
CWE-79Fixed in 1.4.15
- ID
- WPSEC-2026-2404
- Plugin
- Posts Table with Search & Sort (posts-data-table)
- Affected
- from 1.1 before 1.4.15
- Remediation
- Update to 1.4.15 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Posts Table with Search & Sort on WPSec AttackSurface
- Fix released
- Published
Description
The Posts Table with Search & Sort plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'date_format' attribute of the plugin's posts table shortcode in all versions up to, and including, 1.4.14 due to insufficient input sanitization and output escaping of the formatted post date. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2404/
- https://plugins.svn.wordpress.org/posts-data-table/tags/1.4.15/
- https://wordpress.org/plugins/posts-data-table/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS