Vulnerabilities / Open Source Event Calendar / WPSEC-2026-2411
Open Source Event Calendar <= 1.2.0 - Authenticated (Author+) Missing Authorization to Sensitive Information Exposure via Bulk Clone
Medium 4.3
CWE-862Fixed in 1.2.1
- ID
- WPSEC-2026-2411
- Plugin
- Open Source Event Calendar (open-source-event-calendar)
- Affected
- all versions before 1.2.1
- Remediation
- Update to 1.2.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Open Source Event Calendar on WPSec AttackSurface
- Fix released
- Published
Description
The Open Source Event Calendar plugin for WordPress is vulnerable to unauthorized access of data via the bulk 'clone' action in all versions up to, and including, 1.2.0. This is due to a missing check that the current user may read the posts being cloned, and that they are events at all. This makes it possible for authenticated attackers with author-level access and above (or the plugin's Event Contributor role) to clone private, draft or password-protected posts of any type that belong to other users. The attacker then owns the copy and can read its content and all of its post meta.
References
- https://wpsec.com/vuln/WPSEC-2026-2411/
- https://plugins.svn.wordpress.org/open-source-event-calendar/tags/1.2.1/
- https://wordpress.org/plugins/open-source-event-calendar/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS