Vulnerabilities / Open Source Event Calendar / WPSEC-2026-2412
Open Source Event Calendar <= 1.2.0 - Authenticated (Author+) Stored Cross-Site Scripting via Parent Event Title
Medium 6.4
CWE-79Fixed in 1.2.1
- ID
- WPSEC-2026-2412
- Plugin
- Open Source Event Calendar (open-source-event-calendar)
- Affected
- all versions before 1.2.1
- Remediation
- Update to 1.2.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Open Source Event Calendar on WPSec AttackSurface
- Fix released
- Published
Description
The Open Source Event Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the parent event title, which is shown in the 'Base Event' row action of the admin event list, in all versions up to, and including, 1.2.0. This is due to insufficient output escaping of the title inside an HTML title attribute. This makes it possible for authenticated attackers with author-level access and above (or the plugin's Event Contributor role) to inject arbitrary web scripts. The scripts run whenever an administrator or editor views the event list.
References
- https://wpsec.com/vuln/WPSEC-2026-2412/
- https://plugins.svn.wordpress.org/open-source-event-calendar/tags/1.2.1/
- https://wordpress.org/plugins/open-source-event-calendar/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS