Open Source Event Calendar <= 1.2.0 - Authenticated (Author+) Missing Authorization to Arbitrary Post Modification via 'Edit this instance'
- ID
- WPSEC-2026-2413
- Plugin
- Open Source Event Calendar (open-source-event-calendar)
- Affected
- all versions before 1.2.1
- Remediation
- Update to 1.2.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- Weakness
- CWE-862
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
- Attack surface
- Open Source Event Calendar on WPSec AttackSurface
- Fix released
- Published
Description
The Open Source Event Calendar plugin for WordPress is vulnerable to unauthorized modification of data via the 'Edit this instance' occurrence handler (EventParent::admin_init_post() and EventEditing::create_duplicate_post()) in all versions up to, and including, 1.2.0. This is due to a missing capability check on the submitted post_ID, and to the handler passing every submitted post field (such as ID, post_type and meta_input) to wp_insert_post(). The handler runs on admin_action_editpost, before WordPress core's own edit checks. This makes it possible for authenticated attackers with author-level access and above (or the plugin's Event Contributor role) to change other users' events and their recurrence dates, and to overwrite arbitrary posts and add arbitrary post meta.
References
- https://wpsec.com/vuln/WPSEC-2026-2413/
- https://plugins.svn.wordpress.org/open-source-event-calendar/tags/1.2.1/
- https://wordpress.org/plugins/open-source-event-calendar/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS