Vulnerabilities / Vidplex / WPSEC-2026-2414

Vidplex <= 1.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block Font Family Attributes

Medium 6.4 CWE-79Fixed in 1.0.4
ID
WPSEC-2026-2414
Plugin
Vidplex – Ultimate Video Gallery Block for YouTube in Gutenberg (vidplex)
Affected
all versions before 1.0.4
Remediation
Update to 1.0.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-03
Attack surface
Vidplex on WPSec AttackSurface
Fix released
Published

Description

The Vidplex plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the font family attributes of the Grid Carousel and Channel Details blocks in all versions up to, and including, 1.0.3, due to insufficient input sanitization and output escaping. The raw font family values are put into a Google Fonts URL that is echoed inside a link tag's href attribute without escaping or URL encoding. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page containing the block.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0