Vulnerabilities / Elementor / WPSEC-2026-2417

Elementor <= 4.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via SVG Icon Settings

Medium 6.4 CWE-79Fixed in 4.3.6
ID
WPSEC-2026-2417
Plugin
Elementor Website Builder – more than just a page builder (elementor)
Affected
all versions before 4.3.6
Remediation
Update to 4.3.6 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-03
Attack surface
Elementor on WPSec AttackSurface
Fix released
Published

Description

The Elementor Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG icon control settings in all versions up to, and including, 4.3.5, due to the plugin saving the client-supplied SVG URL of icon controls as-is instead of rebuilding it from a verified SVG attachment. The editor then fetches that URL and inserts the response into the page without sanitizing it. This makes it possible for authenticated attackers, with contributor-level access and above, to point an icon at an attacker-controlled SVG file that runs arbitrary scripts when another user, such as an administrator, opens the affected page in the Elementor editor.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0