Vulnerabilities / Elementor / WPSEC-2026-2418

Elementor <= 4.3.5 - Authenticated (Contributor+) Protected Post Meta Injection via 'meta' Parameter

Medium 4.3 CWE-915Fixed in 4.3.6
ID
WPSEC-2026-2418
Plugin
Elementor Website Builder – more than just a page builder (elementor)
Affected
from 3.8.0 before 4.3.6
Remediation
Update to 4.3.6 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-915
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-03
Attack surface
Elementor on WPSec AttackSurface
Fix released
Published

Description

The Elementor Website Builder plugin for WordPress is vulnerable to protected post meta injection via the 'meta' parameter of the create new post action in versions 3.8.0 up to, and including, 4.3.5 due to arbitrary meta keys from the request being saved without rejecting protected (underscore-prefixed) keys. This makes it possible for authenticated attackers, with contributor-level access and above who can create Elementor posts, to set internal protected meta on newly created posts, such as the Elementor page data, which then skips the filtering Elementor applies when a page is saved.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0