Vulnerabilities / Advanced Custom Fields (ACF®) / WPSEC-2026-2419
Advanced Custom Fields (ACF®) <= 6.8.10 - Authenticated (Contributor+) Missing Authorization to Bidirectional Relationship Modification
Medium 4.3
CWE-862Fixed in 6.8.11
- ID
- WPSEC-2026-2419
- Plugin
- Advanced Custom Fields (ACF®) (advanced-custom-fields)
- Affected
- from 6.2.0 before 6.8.11
- Remediation
- Update to 6.8.11 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-862
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-03
- Attack surface
- Advanced Custom Fields (ACF®) on WPSec AttackSurface
- Fix released
- Published
Description
The Advanced Custom Fields (ACF®) plugin for WordPress is vulnerable to unauthorized modification of data in all versions up to, and including, 6.8.10 due to a missing capability check when bidirectional relationship fields sync references. The plugin wrote back-references onto target posts, users and terms without checking whether the current user could edit or assign them. This makes it possible for authenticated attackers with contributor-level access and above to modify relational field values stored on posts, terms and users they are not allowed to edit.
References
- https://wpsec.com/vuln/WPSEC-2026-2419/
- https://plugins.svn.wordpress.org/advanced-custom-fields/tags/6.8.11/
- https://wordpress.org/plugins/advanced-custom-fields/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS