Vulnerabilities / BuddyDrive / WPSEC-2026-2425

BuddyDrive <= 2.1.4 - Unauthenticated Sensitive Information Exposure via File Lists

Medium 5.3 CWE-200Fixed in 2.1.5
ID
WPSEC-2026-2425
Plugin
BuddyDrive (buddydrive)
Affected
all versions before 2.1.5
Remediation
Update to 2.1.5 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-200
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
Attack surface
BuddyDrive on WPSec AttackSurface
Fix released
Published

Description

The BuddyDrive plugin for WordPress is vulnerable to Sensitive Information Exposure via the buddydrive_fetch_items AJAX action in all versions up to, and including, 2.1.4, due to the returned file list only excluding private items of other users instead of applying the item access rules. This makes it possible for unauthenticated attackers to list the names, owners, links and sharing details of files and folders that are shared only with specific groups, friends or members.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0