Vulnerabilities / WP Docs / WPSEC-2026-2428

WP Docs <= 2.3.5 - Authenticated (Contributor+) SQL Injection via 'orderby' and 'order' Shortcode Attributes

Medium 6.5 CWE-89Fixed in 2.3.6
ID
WPSEC-2026-2428
Plugin
WP Docs (wp-docs)
Affected
all versions before 2.3.6
Remediation
Update to 2.3.6 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-89
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-03
Attack surface
WP Docs on WPSec AttackSurface
Fix released
Published

Description

The WP Docs plugin for WordPress is vulnerable to SQL Injection via the 'orderby' and 'order' attributes of the [wpdocs] shortcode in all versions up to, and including, 2.3.5 due to insufficient escaping and validation of the user-supplied values, which are concatenated directly into the ORDER BY clause of an SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL to existing queries and extract sensitive information from the database.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0