Vulnerabilities / WP Popular Posts / WPSEC-2026-2432

WP Popular Posts <= 7.4.3 - Authenticated (Author+) Blind Server-Side Request Forgery via Post Image URLs

Medium 4.9 CWE-918Fixed in 7.4.4
ID
WPSEC-2026-2432
Plugin
WP Popular Posts (wordpress-popular-posts)
Affected
all versions before 7.4.4
Remediation
Update to 7.4.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-918
Usage
Plugin High · Affected versions High among sites WPSec scans, 2026-11-04
Attack surface
WP Popular Posts on WPSec AttackSurface
Fix released
Published

Description

The WP Popular Posts plugin for WordPress is vulnerable to blind Server-Side Request Forgery via external thumbnail images in all versions up to, and including, 7.4.3. This is due to the fetch_external_image() function sending a wp_remote_head() request to the image URL without the reject_unsafe_urls option and with SSL verification turned off. When the thumbnail source is set to 'First image on post' or 'Custom field', the URL comes from the post content or a custom field. This makes it possible for authenticated attackers, with author-level access and above, to publish a post with a crafted image URL, which makes the web server send HEAD requests to arbitrary locations, including internal and loopback hosts, whenever the post shows in a popular posts list.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0