Vulnerabilities / All-in-One Video Gallery / WPSEC-2026-2448
All-in-One Video Gallery <= 5.0.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'image' Post Meta
Medium 6.4
CWE-79Fixed in 5.1.0
- ID
- WPSEC-2026-2448
- Plugin
- All-in-One Video Gallery – Video Player & Galleries for YouTube, Vimeo & Self-Hosted Videos (all-in-one-video-gallery)
- Affected
- all versions before 5.1.0
- Remediation
- Update to 5.1.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- All-in-One Video Gallery on WPSec AttackSurface
- Fix released
- Published
Description
The All-in-One Video Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'image' video post meta in all versions up to, and including, 5.0.0 due to insufficient input sanitization of the meta value when it is written (for example through XML-RPC custom fields) and missing output escaping when it is printed in the admin video list. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts that execute whenever a user, such as an administrator, accesses an affected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2448/
- https://plugins.svn.wordpress.org/all-in-one-video-gallery/tags/5.1.0/
- https://wordpress.org/plugins/all-in-one-video-gallery/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS