Vulnerabilities / WP Customer Area / WPSEC-2026-2454

WP Customer Area <= 8.4.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'customer-area-protected-content' Shortcode 'layout' and 'title' Attributes

Medium 6.4 CWE-79Fixed in 8.4.4
ID
WPSEC-2026-2454
Plugin
WP Customer Area (customer-area)
Affected
all versions before 8.4.4
Remediation
Update to 8.4.4 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
Attack surface
WP Customer Area on WPSec AttackSurface
Fix released
Published

Description

The WP Customer Area plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'layout' and 'title' attributes of the [customer-area-protected-content] shortcode in all versions up to, and including, 8.4.3, due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a logged-in user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0