Vulnerabilities / MC4WP: Mailchimp for WordPress / WPSEC-2026-2462
MC4WP: Mailchimp for WordPress <= 4.14.1 - Unauthenticated Insecure Direct Object Reference to Arbitrary Audience Subscription via '_mc4wp_lists' Parameter
Medium 5.3
CWE-639Fixed in 4.15.0
- ID
- WPSEC-2026-2462
- Plugin
- MC4WP: Mailchimp for WordPress (mailchimp-for-wp)
- Affected
- all versions before 4.15.0
- Remediation
- Update to 4.15.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weakness
- CWE-639
- Usage
- Plugin High · Affected versions High among sites WPSec scans, 2026-11-04
- Attack surface
- MC4WP: Mailchimp for WordPress on WPSec AttackSurface
- Fix released
- Published
Description
The MC4WP: Mailchimp for WordPress plugin for WordPress is vulnerable to Insecure Direct Object Reference via the '_mc4wp_lists' parameter in all versions up to, and including, 4.14.1. This is due to sign-up form submissions and integrations (such as the comment form, registration form and Contact Form 7) accepting user-supplied Mailchimp list IDs without checking that the site owner selected those lists for that form or integration. This makes it possible for unauthenticated attackers to subscribe arbitrary email addresses to any audience in the connected Mailchimp account.
References
- https://wpsec.com/vuln/WPSEC-2026-2462/
- https://plugins.svn.wordpress.org/mailchimp-for-wp/tags/4.15.0/
- https://wordpress.org/plugins/mailchimp-for-wp/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS