Vulnerabilities / Advanced Order Export For WooCommerce / WPSEC-2026-2466
Advanced Order Export For WooCommerce <= 4.1.3 - Authenticated (Shop Manager+) SQL Injection via Product Category Filter
Medium 4.9
CWE-89Fixed in 4.1.4
- ID
- WPSEC-2026-2466
- Plugin
- Advanced Order Export For WooCommerce (woo-order-export-lite)
- Affected
- all versions before 4.1.4
- Remediation
- Update to 4.1.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- Weakness
- CWE-89
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
- Attack surface
- Advanced Order Export For WooCommerce on WPSec AttackSurface
- Fix released
- Published
Description
The Advanced Order Export For WooCommerce plugin for WordPress is vulnerable to SQL Injection via the product category export filter in all versions up to, and including, 4.1.3 due to insufficient validation of the user-supplied category IDs and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers with Shop Manager-level access and above, or any user given the plugin's export capability, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
References
- https://wpsec.com/vuln/WPSEC-2026-2466/
- https://plugins.svn.wordpress.org/woo-order-export-lite/tags/4.1.4/
- https://wordpress.org/plugins/woo-order-export-lite/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS