Vulnerabilities / LatePoint / WPSEC-2026-2477

LatePoint <= 5.7.7 - Unauthenticated Insecure Direct Object Reference to Invoice Disclosure via 'key' Parameter

Medium 5.3 CWE-639Fixed in 5.7.8
ID
WPSEC-2026-2477
Plugin
Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress (latepoint)
Affected
all versions before 5.7.8
Remediation
Update to 5.7.8 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-639
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
Attack surface
LatePoint on WPSec AttackSurface
Fix released
Published

Description

The LatePoint plugin for WordPress is vulnerable to Insecure Direct Object Reference via the 'key' parameter of the public invoice view, payment form and payment summary actions in all versions up to, and including, 5.7.7, due to the model query builder treating the literal strings 'IS NULL' and 'IS NOT NULL' supplied in user input as SQL null-check operators instead of binding them as values. This makes it possible for unauthenticated attackers to bypass the invoice access key check and view an invoice, which may contain customer and order details, without knowing its secret access key.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0