Vulnerabilities / LifterLMS / WPSEC-2026-2481

LifterLMS <= 10.3.2 - Authenticated (Subscriber+) HTML Injection via Quiz Attempt Answers

Low 3.5 CWE-79Fixed in 11.0.0
ID
WPSEC-2026-2481
Plugin
LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes (lifterlms)
Affected
all versions before 11.0.0
Remediation
Update to 11.0.0 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
Attack surface
LifterLMS on WPSec AttackSurface
Fix released
Published

Description

The LifterLMS plugin for WordPress is vulnerable to HTML Injection via quiz attempt answers in all versions up to, and including, 10.3.2 due to insufficient sanitization of student-submitted answer HTML, which allowed form controls and data-* attributes, before it is displayed to instructors inside the quiz grading form. This makes it possible for authenticated attackers with student (subscriber-level) access to inject form fields and data attributes that the grading scripts read, which can manipulate the grading form when an instructor reviews the attempt.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0