Vulnerabilities / AutomatorWP / WPSEC-2026-2485

AutomatorWP <= 6.0.6 - Missing Authorization to Unauthenticated Zoom Integration OAuth Token Overwrite

Low 3.7 CWE-862Fixed in 6.0.7
ID
WPSEC-2026-2485
Plugin
AutomatorWP – No-Code Workflow Automation, Integration & Webhooks Plugin, now with AI (automatorwp)
Affected
all versions before 6.0.7
Remediation
Update to 6.0.7 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-04
Attack surface
AutomatorWP on WPSec AttackSurface
Fix released
Published

Description

The AutomatorWP plugin for WordPress is vulnerable to unauthorized modification of data via the Zoom OAuth authorization callback in all versions up to, and including, 6.0.6, due to a missing capability check on the automatorwp_zoom_maybe_authorize_complete function. The function is hooked to admin_init, which also runs for logged-out requests to admin-post.php and admin-ajax.php. This makes it possible for unauthenticated attackers to make the site exchange an OAuth authorization code they supply for the configured Zoom app and save the resulting access and refresh tokens. The site's Zoom integration is then connected to an account the attacker controls.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0