Vulnerabilities / Abstracts / WPSEC-2026-2490

Abstracts <= 2.7.6 - Missing Authorization to Authenticated (Subscriber+) Topic Reordering

Medium 4.3 CWE-862Fixed in 2.7.7
ID
WPSEC-2026-2490
Plugin
WP Abstracts (wp-abstracts-manuscripts-manager)
Affected
from 2.7.4 before 2.7.7
Remediation
Update to 2.7.7 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weakness
CWE-862
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-04
Attack surface
Abstracts on WPSec AttackSurface
Fix released
Published

Description

The WP Abstracts plugin for WordPress is vulnerable to unauthorized modification of data via the reorder_topics AJAX action in all versions up to, and including, 2.7.6, due to a missing capability check on the wpabstracts_reorder_topics() function, which is protected only by a nonce that is given to front-end users. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change the display order of event topics.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0