Vulnerabilities / Wbcom Designs – BuddyPress Group Reviews / WPSEC-2026-2493
Wbcom Designs – BuddyPress Group Reviews <= 3.9.0 - Unauthenticated Sensitive Information Exposure of Unpublished Reviews via REST API
Medium 5.3
CWE-200Fixed in 3.9.1
- ID
- WPSEC-2026-2493
- Plugin
- Wbcom Designs – BuddyPress Group Reviews (review-buddypress-groups)
- Affected
- from 3.5.0 before 3.9.1
- Remediation
- Update to 3.9.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-04
- Attack surface
- Wbcom Designs – BuddyPress Group Reviews on WPSec AttackSurface
- Fix released
- Published
Description
The BuddyPress Group Reviews plugin for WordPress is vulnerable to Sensitive Information Exposure via the single group review REST API endpoint (buddypress/v1/groups/<group_id>/reviews/<review_id>) in all versions up to, and including, 3.9.0, due to the endpoint only checking that the review belongs to the supplied group, not that it is published or that the requester may edit it. This makes it possible for unauthenticated attackers to read the content, author and ratings of draft (pending moderation) and trashed (denied) reviews.
References
- https://wpsec.com/vuln/WPSEC-2026-2493/
- https://plugins.svn.wordpress.org/review-buddypress-groups/tags/3.9.1/
- https://wordpress.org/plugins/review-buddypress-groups/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS