Vulnerabilities / Unlimited Elements for Elementor / WPSEC-2026-2502
Unlimited Elements for Elementor <= 2.0.26 - Reflected Cross-Site Scripting via Search Suggestion
Medium 6.1
CWE-79Fixed in 2.0.28
- ID
- WPSEC-2026-2502
- Plugin
- Unlimited Elements for Elementor (unlimited-elements-for-elementor)
- Affected
- all versions before 2.0.28
- Remediation
- Update to 2.0.28 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-04
- Attack surface
- Unlimited Elements for Elementor on WPSec AttackSurface
- Fix released
- Published
Description
The Unlimited Elements for Elementor plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the AJAX search suggestion feature in all versions up to, and including, 2.0.26 due to insufficient input sanitization and output escaping of the search term returned in the suggestion response. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
References
- https://wpsec.com/vuln/WPSEC-2026-2502/
- https://plugins.svn.wordpress.org/unlimited-elements-for-elementor/tags/2.0.28/
- https://wordpress.org/plugins/unlimited-elements-for-elementor/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS