WPeMatico RSS Feed Fetcher <= 2.9.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Campaign Categories

Medium 6.4 CWE-79Fixed in 2.9.2
ID
WPSEC-2026-2507
Plugin
WPeMatico RSS Feed Fetcher (wpematico)
Affected
all versions before 2.9.2
Remediation
Update to 2.9.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-04
Attack surface
WPeMatico RSS Feed Fetcher on WPSec AttackSurface
Fix released
Published

Description

The WPeMatico RSS Feed Fetcher plugin for WordPress is vulnerable to Stored Cross-Site Scripting via campaign categories in all versions up to, and including, 2.9.1, due to insufficient input sanitization and output escaping. The categories of a campaign were stored as submitted instead of as category IDs, and were written unescaped into the hidden quick-edit data of the campaigns list. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts that execute when an administrator views the campaigns list.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0