Vulnerabilities / WZ Followed Posts – Display what visitors are reading / WPSEC-2026-2512
WZ Followed Posts – Display what visitors are reading <= 3.4.3 - Unauthenticated Sensitive Information Exposure via Cached Password-Protected Post Output
Low 3.7
CWE-524Fixed in 3.4.4
- ID
- WPSEC-2026-2512
- Plugin
- WZ Followed Posts – Display what visitors are reading (where-did-they-go-from-here)
- Affected
- all versions before 3.4.4
- Remediation
- Update to 3.4.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-524
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-04
- Attack surface
- WZ Followed Posts – Display what visitors are reading on WPSec AttackSurface
- Fix released
- Published
Description
The WZ Followed Posts plugin for WordPress is vulnerable to Sensitive Information Exposure via the followed posts output cache in all versions up to, and including, 3.4.3, due to the plugin caching output that was generated for a visitor who had unlocked a password-protected post and serving that output to everyone. This makes it possible for unauthenticated attackers to read excerpts of password-protected posts after a visitor who knows the password has loaded a page whose followed posts list includes such a post. Excerpts and caching must both be enabled.
References
- https://wpsec.com/vuln/WPSEC-2026-2512/
- https://plugins.svn.wordpress.org/where-did-they-go-from-here/tags/3.4.4/
- https://wordpress.org/plugins/where-did-they-go-from-here/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS