Vulnerabilities / WPGraphQL / WPSEC-2026-2525

WPGraphQL <= 2.26.0 - Unauthenticated Sensitive Information Exposure via Comments Connection Filters

Medium 5.3 CWE-203Fixed in 2.26.1
ID
WPSEC-2026-2525
Plugin
WPGraphQL (wp-graphql)
Affected
all versions before 2.26.1
Remediation
Update to 2.26.1 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weakness
CWE-203
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-04
Attack surface
WPGraphQL on WPSec AttackSurface
Fix released
Published

Description

The WPGraphQL plugin for WordPress is vulnerable to Sensitive Information Exposure via the comments connection in all versions up to, and including, 2.26.0 due to insufficient restriction of query arguments, search, ordering and cursors for users who cannot moderate comments. This makes it possible for unauthenticated attackers to use filtering by author email, searching (which matches author email and IP address), ordering by email, IP or user agent, and status, content and cursor filters as an oracle to infer commenters' email addresses and IP addresses and the existence of unapproved comments or comments on private and draft content.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0