weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot <= 2.6.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode and Elementor Widgets
- ID
- WPSEC-2026-2537
- Plugin
- weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot (wedocs)
- Affected
- all versions before 2.6.2
- Remediation
- Update to 2.6.2 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-05
- Attack surface
- weDocs: AI Powered Knowledge Base, Docs, Documentation, Wiki & AI Chatbot on WPSec AttackSurface
- Fix released
- Published
Description
The weDocs plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the [wedocs] shortcode's 'more' attribute and the Docs Grid and Table of Contents Elementor widgets in all versions up to, and including, 2.6.1. This is due to insufficient input sanitization and output escaping: the 'more' label and the list divider colour are printed unescaped, and the Table of Contents script inserts decoded heading text as HTML. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts into pages that will execute whenever a user accesses an injected page.
References
- https://wpsec.com/vuln/WPSEC-2026-2537/
- https://plugins.svn.wordpress.org/wedocs/tags/2.6.2/
- https://wordpress.org/plugins/wedocs/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS