Vulnerabilities / VK All in One Expansion Unit / WPSEC-2026-2542
VK All in One Expansion Unit <= 9.123.1 - Unauthenticated Sensitive Information Exposure via Child Page List
Medium 5.3
CWE-200Fixed in 9.124.0
- ID
- WPSEC-2026-2542
- Plugin
- VK All in One Expansion Unit (vk-all-in-one-expansion-unit)
- Affected
- all versions before 9.124.0
- Remediation
- Update to 9.124.0 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
- Attack surface
- VK All in One Expansion Unit on WPSec AttackSurface
- Fix released
- Published
Description
The VK All in One Expansion Unit plugin for WordPress is vulnerable to Sensitive Information Exposure via the Child Page List feature in all versions up to, and including, 9.123.1. This is due to the child page excerpt helper not checking whether a child page is password-protected before outputting its excerpt or the beginning of its content. This makes it possible for unauthenticated attackers to read the excerpt or opening content of password-protected pages without knowing the password.
References
- https://wpsec.com/vuln/WPSEC-2026-2542/
- https://plugins.svn.wordpress.org/vk-all-in-one-expansion-unit/tags/9.124.0/
- https://wordpress.org/plugins/vk-all-in-one-expansion-unit/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS