Vulnerabilities / Live Composer / WPSEC-2026-2548

Live Composer <= 2.1.22 - Authenticated (Contributor+) Stored Cross-Site Scripting via Pagination Module Options

Medium 6.4 CWE-79Fixed in 2.1.23
ID
WPSEC-2026-2548
Plugin
Live Composer – Free WordPress Website Builder (live-composer-page-builder)
Affected
all versions before 2.1.23
Remediation
Update to 2.1.23 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-05
Attack surface
Live Composer on WPSec AttackSurface
Fix released
Published

Description

The Live Composer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the pagination type and pagination text module options in all versions up to, and including, 2.1.22, due to insufficient input validation and output escaping in the shared dslc_post_pagination() helper used by the post listing modules. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0