Vulnerabilities / Live Composer / WPSEC-2026-2549

Live Composer <= 2.1.22 - Authenticated (Author+) Stored Cross-Site Scripting via Custom URL Post Meta

Medium 6.4 CWE-79Fixed in 2.1.23
ID
WPSEC-2026-2549
Plugin
Live Composer – Free WordPress Website Builder (live-composer-page-builder)
Affected
all versions before 2.1.23
Remediation
Update to 2.1.23 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-05
Attack surface
Live Composer on WPSec AttackSurface
Fix released
Published

Description

The Live Composer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the custom URL post meta of Projects (dslc_project_url), Partners (dslc_partner_url) and Galleries (dslc_custom_url) items in all versions up to, and including, 2.1.22, due to insufficient input sanitization and output escaping of these URLs in anchor href attributes rendered by the Projects, Partners and Galleries modules. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses a page displaying the affected module.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0