Vulnerabilities / AutomatorWP / WPSEC-2026-2574

AutomatorWP <= 6.0.7 - Cross-Site Request Forgery via Zoom OAuth Callback

Low 3.1 CWE-352Fixed in 6.0.8
ID
WPSEC-2026-2574
Plugin
AutomatorWP – No-Code Workflow Automation, Integration & Webhooks Plugin, now with AI (automatorwp)
Affected
all versions before 6.0.8
Remediation
Update to 6.0.8 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
Weakness
CWE-352
Usage
Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-05
Attack surface
AutomatorWP on WPSec AttackSurface
Fix released
Published

Description

The AutomatorWP plugin for WordPress is vulnerable to Cross-Site Request Forgery via the Zoom OAuth authorization callback in all versions up to, and including, 6.0.7, due to the automatorwp_zoom_maybe_authorize_complete() function using the 'state' parameter only to pick the platform, with no nonce check, before an authorization code is exchanged for tokens. This makes it possible for unauthenticated attackers who hold an authorization code issued for the site's Zoom app to link the site's Zoom integration to a Zoom account they control via a forged request, granted they can trick a site administrator into clicking a crafted callback link.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0