Vulnerabilities / If-So Dynamic Content / WPSEC-2026-2597
If-So Dynamic Content <= 1.10.3 - Unauthenticated Arbitrary Shortcode Execution via Dynamic Keyword Insertion (ifsoDKI) Shortcode
Medium 6.5
CWE-94Fixed in 1.10.4
- ID
- WPSEC-2026-2597
- Plugin
- If-So Dynamic Content – Elementor & All Page Builders Personalization (if-so)
- Affected
- all versions before 1.10.4
- Remediation
- Update to 1.10.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weakness
- CWE-94
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
- Attack surface
- If-So Dynamic Content on WPSec AttackSurface
- Fix released
- Published
Description
The If-So Dynamic Content plugin for WordPress is vulnerable to arbitrary shortcode execution via the Dynamic Keyword Insertion (ifsoDKI) shortcode in all versions up to, and including, 1.10.3. This is due to the plugin inserting request-derived values, such as URL query parameters, into the page output without neutralizing square brackets, which WordPress then processes as shortcodes. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes by crafting a URL to a page that uses the DKI shortcode.
References
- https://wpsec.com/vuln/WPSEC-2026-2597/
- https://plugins.svn.wordpress.org/if-so/tags/1.10.4/
- https://wordpress.org/plugins/if-so/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS