Admin Management Xtended <= 2.5.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Post Title
- ID
- WPSEC-2026-2598
- Plugin
- Admin Management Xtended (admin-management-xtended)
- Affected
- all versions before 2.5.4
- Remediation
- Update to 2.5.4 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weakness
- CWE-79
- Usage
- Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-05
- Attack surface
- Admin Management Xtended on WPSec AttackSurface
- Fix released
- Published
Description
The Admin Management Xtended plugin for WordPress is vulnerable to Stored Cross-Site Scripting via post titles in all versions up to, and including, 2.5.3. This is due to insufficient output escaping in the inline title edit feature: the rendered post title is read back from the posts/pages list and concatenated unescaped into an inline onclick attribute, and then into the HTML of the title edit input. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts into a post title. The scripts run when an editor or administrator views or interacts with the posts or pages list.
References
- https://wpsec.com/vuln/WPSEC-2026-2598/
- https://plugins.svn.wordpress.org/admin-management-xtended/tags/2.5.4/
- https://wordpress.org/plugins/admin-management-xtended/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS