Vulnerabilities / Fusion Page Builder / WPSEC-2026-2599
Fusion Page Builder <= 1.6.7 - Authenticated (Contributor+) Sensitive Information Exposure via Template Loader
Medium 4.3
CWE-639Fixed in 1.7.1
- ID
- WPSEC-2026-2599
- Plugin
- Fusion Page Builder (fusion)
- Affected
- all versions before 1.7.1
- Remediation
- Update to 1.7.1 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weakness
- CWE-639
- Usage
- Plugin Low · Affected versions Low among sites WPSec scans, 2026-11-05
- Attack surface
- Fusion Page Builder on WPSec AttackSurface
- Fix released
- Published
Description
The Fusion Page Builder plugin for WordPress is vulnerable to Sensitive Information Exposure via the template load AJAX handler in all versions up to, and including, 1.6.7 due to the handler rendering the content of any published post ID without verifying that it belongs to the template post type. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the rendered content of arbitrary published posts, including password-protected posts and posts of non-public post types.
References
- https://wpsec.com/vuln/WPSEC-2026-2599/
- https://plugins.svn.wordpress.org/fusion/tags/1.7.1/
- https://wordpress.org/plugins/fusion/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS