Vulnerabilities / Leaky Paywall / WPSEC-2026-2605

Leaky Paywall <= 5.3.1 - Unauthenticated Stored Cross-Site Scripting via Registration Form Fields

High 7.2 CWE-79Fixed in 5.3.2
ID
WPSEC-2026-2605
Plugin
Leaky Paywall (leaky-paywall)
Affected
from 4.16.7 before 5.3.2
Remediation
Update to 5.3.2 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Low · Affected versions None seen among sites WPSec scans, 2026-11-05
Attack surface
Leaky Paywall on WPSec AttackSurface
Fix released
Published

Description

The Leaky Paywall plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the registration form's first and last name fields in all versions up to, and including, 5.3.1. This is due to insufficient input sanitization of the decoded 'form_data' fields, which are passed into the Stripe customer that is saved on the incomplete-user record, and insufficient output escaping when the Incomplete Users admin screen prints that customer data. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that execute whenever an administrator views the affected incomplete-user record.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0