Vulnerabilities / WP Data Access / WPSEC-2026-2609

WP Data Access <= 5.5.90 - Authenticated (Contributor+) Stored Cross-Site Scripting via Data Entry Form Textarea

Medium 6.4 CWE-79Fixed in 5.5.91
ID
WPSEC-2026-2609
Plugin
WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps (wp-data-access)
Affected
from 5.5.86 before 5.5.91
Remediation
Update to 5.5.91 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
Attack surface
WP Data Access on WPSec AttackSurface
Fix released
Published

Description

The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site Scripting via text column values displayed in data entry form textarea fields in all versions up to, and including, 5.5.90, due to insufficient output escaping. The column value was echoed inside the textarea element with only ampersands encoded. This makes it possible for authenticated attackers, with contributor-level access and above, who can store unfiltered data in a text column (such as raw post meta values) that is opened in the plugin's data entry form, to inject arbitrary web scripts that execute whenever an administrator views or edits the affected record.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0