Vulnerabilities / Greenshift / WPSEC-2026-2610
Greenshift <= 13.2.2 - Authenticated (Contributor+) Sensitive Information Exposure via Reusable Block Shortcode
Medium 6.5
CWE-200Fixed in 13.2.3
- ID
- WPSEC-2026-2610
- Plugin
- Greenshift – animation and page builder blocks (greenshift-animation-and-page-builder-blocks)
- Affected
- all versions before 13.2.3
- Remediation
- Update to 13.2.3 or later.
- CVSS 3.1
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weakness
- CWE-200
- Usage
- Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
- Attack surface
- Greenshift on WPSec AttackSurface
- Fix released
- Published
Description
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Sensitive Information Exposure via the 'wp_reusable_render' shortcode in all versions up to, and including, 13.2.2, due to the gspb_template_shortcode_function() function rendering any wp_block post by ID without checking its post status or password protection. This makes it possible for authenticated attackers, with contributor-level access and above, to embed and read the content of draft, private or password-protected reusable blocks (synced patterns).
References
- https://wpsec.com/vuln/WPSEC-2026-2610/
- https://plugins.svn.wordpress.org/greenshift-animation-and-page-builder-blocks/tags/13.2.3/
- https://wordpress.org/plugins/greenshift-animation-and-page-builder-blocks/
Published by WPSec. Provided as is, without warranty. Corrections: contact us.
This advisory as JSON or Markdown · All advisories: JSON, RSS