Vulnerabilities / Greenshift / WPSEC-2026-2611

Greenshift <= 13.2.2 - Authenticated (Contributor+) Sensitive Information Exposure via {{COOKIE:}} Dynamic Placeholder

Medium 5.7 CWE-200Fixed in 13.2.3
ID
WPSEC-2026-2611
Plugin
Greenshift – animation and page builder blocks (greenshift-animation-and-page-builder-blocks)
Affected
from 10.8 before 13.2.3
Remediation
Update to 13.2.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
Attack surface
Greenshift on WPSec AttackSurface
Fix released
Published

Description

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Sensitive Information Exposure via the {{COOKIE:...}} dynamic placeholder in all versions up to, and including, 13.2.2, due to the placeholder printing any cookie, including WordPress authentication, logged-in, session and post password cookies, into block markup such as element src/href or dynamic attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to make a higher-privileged user who views or previews their post send that user's HttpOnly login cookie to an attacker-controlled host, which can lead to session hijacking.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0