Vulnerabilities / Greenshift / WPSEC-2026-2612

Greenshift <= 13.2.2 - Unauthenticated Sensitive Information Exposure via Nested Dynamic Placeholders

Medium 5.3 CWE-200Fixed in 13.2.3
ID
WPSEC-2026-2612
Plugin
Greenshift – animation and page builder blocks (greenshift-animation-and-page-builder-blocks)
Affected
from 10.8 before 13.2.3
Remediation
Update to 13.2.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
Weakness
CWE-200
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
Attack surface
Greenshift on WPSec AttackSurface
Fix released
Published

Description

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Sensitive Information Exposure via the {{GET:...}} dynamic placeholder in all versions up to, and including, 13.2.2, due to visitor-supplied GET (and FORM) values keeping their braces. Placeholders resolved later in the same pass, such as {{COOKIE:...}} and {{USER_META:...}}, are then filled in. On sites that use a {{GET:...}} placeholder in a URL attribute, this makes it possible for unauthenticated attackers to craft a link that sends a logged-in victim's login cookie or user meta to an attacker-controlled host.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0