Vulnerabilities / Greenshift / WPSEC-2026-2613

Greenshift <= 13.2.2 - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via Counter Prefix/Postfix and Typewriter Text

Medium 6.4 CWE-79Fixed in 13.2.3
ID
WPSEC-2026-2613
Plugin
Greenshift – animation and page builder blocks (greenshift-animation-and-page-builder-blocks)
Affected
all versions before 13.2.3
Remediation
Update to 13.2.3 or later.
CVSS 3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Weakness
CWE-79
Usage
Plugin Medium · Affected versions Medium among sites WPSec scans, 2026-11-05
Attack surface
Greenshift on WPSec AttackSurface
Fix released
Published

Description

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the Counter block prefix and postfix (data-prefix / data-postfix) and the Typewriter text animation (data-type) in all versions up to, and including, 13.2.2, due to the front-end scripts writing these values into the page with innerHTML instead of as text. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts that run whenever a user opens an injected page. The same sink is reached when an Interaction Layer copies attacker-supplied page data onto a Counter prefix.

References

Published by WPSec. Provided as is, without warranty. Corrections: contact us.

This advisory as JSON or Markdown · All advisories: JSON, RSS

License: CC BY 4.0